#最新
文华财经T8量化交易程序源码

2024-02-13 0 42,268

文华财经T8量化交易程序源码

MOMLEN:=5;

AVGLEN:=10;
ATRLEN:=10;
ATRPCNT:=3;
SETUPLEN:=1;
RISK:=MONEYTOT<=INITMONEY*(1-10/100);//风控条件:本金风险率超过10%
RISK,CLOSEOUT;//达到风控条件,模型清仓且不再开仓
MOMVALUE:=C-REF(C,MOMLEN);
VWM:=EMA(VOL*MOMVALUE,AVGLEN);//定义成交量加权为VWM
TRUEHIGH1:=IF(HIGH>REF(C,1),HIGH,REF(C,1));
TRUELOW1:=IF(LOW<=REF(C,1),LOW,REF(C,1));
TRUERANGE1:=IF(ISLASTBAR,H-L,TRUEHIGH1-TRUELOW1);
AATR:=MA(TRUERANGE1,ATRLEN);//定义波动率                           
BULLSETUP:=CROSSUP(VWM,0);//UWM上穿零轴定义多头势
BEARSETUP:=CROSSDOWN(VWM,0);//UWM下穿零轴定义空头势
LSETUP:=LOOP2(BARPOS=1||BULLSETUP,0,REF(LSETUP,1)+1);//多头势开始计数并记录当前价格
LEPRICE:=VALUEWHEN(BULLSETUP,C);
SSETUP:=LOOP2(BARPOS=1||BEARSETUP,0,REF(SSETUP,1)+1);//空头势开始计数并记录当前价格
SEPRICE:=VALUEWHEN(BEARSETUP,C);
//系统入场
//当多头势满足并且在SETUPLEN的BAR数目内,当价格达到入场价格后,做多
NOT(RISK)&&BARPOS>AVGLEN&&H>=REF(LEPRICE,1)+((ATRPCNT/10)*REF(AATR,1))&&REF(LSETUP,1)<=SETUPLEN&&LSETUP>=1,BK;
//系统出场
BEARSETUP,SP;
//系统入场
//当空头势满足并且在SETUPLEN的BAR数目内,当价格达到入场价格后,做空
NOT(RISK)&&BARPOS>AVGLEN&&L<=REF(SEPRICE,1)-((ATRPCNT/10)*REF(AATR,1))&&REF(SSETUP,1)<=SETUPLEN&&SSETUP>=1,SK;
//系统出场
BULLSETUP,BP;
BKVOL>0&&CLOSE<=BKHIGH*(1-10/100),CLOSEOUT;//多单,开多之后的高点为基准回撤10%止损
SKVOL>0&&CLOSE>=SKLOW*(1+10/100),CLOSEOUT;//空单,开空之后的低点为基准回撤10%止损
AUTOFILTER;
文华财经T8量化交易程序源码

常见问题及下载声明: 1、指标不提供具体的使用方法,详情里一般会说明使用建议,需自行学习研究。 2、指标下载后,代表已对该指标认可,顾不退款! 3、指标不会安装,可在首页点击指标公式安装,各大软件指标安装教程。 4、指标是分析学习工具,不能依赖操作,仅供学习之用,依次操作,盈亏自负!

云析赢指标公式网首席工程师

相关文章

发表评论
暂无评论