#最新
通达信三角形画线突破主图指标公式源码

2024-04-18 0 58,647

通达信三角形画线突破主图指标公式源码:

总股本:=STRCAT(STRCAT(‘ 总股本:’,CON2STR(TOTALCAPITAL/1000000,2)),’亿’);

流通盘:=STRCAT(STRCAT(‘ 流通盘:’,CON2STR(CAPITAL/1000000,2)),’亿’);

全流通:=STRCAT(STRCAT(‘ 流通比:’,CON2STR(CAPITAL/TOTALCAPITAL*100,2)),’%’);

市值:=STRCAT(STRCAT(‘ 流通市值:’,CON2STR((CAPITAL/1000000)*C,2)),’亿’);

股本市值:=STRCAT(‘【股本市值】:’,STRCAT(STRCAT(STRCAT(总股本,流通盘),全流通),市值));

市盈率:=STRCAT(‘ 市盈率:’,CON2STR(C/FINANCE(33),2));

净资收益率:=STRCAT(‘ 净资收益率:’,CON2STR(FINANCE(33)/FINANCE(34)*100,2));

主营利润率:=STRCAT(‘ 主营利润率:’,CON2STR(FINANCE(23)/FINANCE(20)*100,2));

当前业绩:=STRCAT(‘【当前业绩】:’,STRCAT(STRCAT(市盈率,净资收益率),主营利润率));

DRAWTEXT_FIX(ISLASTBAR,0.005,0.12,0,股本市值),COLORMAGENTA;

DRAWTEXT_FIX(ISLASTBAR,0.005,0.17,0,当前业绩),COLORMAGENTA;

三角突破1:=REF(H,3)=HHV(H,2*3+1);

三角突破2:=FILTER(三角突破1,3);

三角突破3:=BACKSET(三角突破2,3+1);

三角突破4:=FILTER(三角突破3,3);

三角突破5:=REF(L,3)=LLV(L,2*3+1);

三角突破6:=FILTER(三角突破5,3);

三角突破7:=BACKSET(三角突破6,3+1);

三角突破8:=FILTER(三角突破7,3);

三角突破9:=(REF(LLV(L,2*3),1)+REF(HHV(H,2*3),1))/2;

三角突破10:=(H+L)/2;

三角突破11:=(三角突破4 AND NOT(三角突破8 AND 三角突破9>=三角突破10)) OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;

三角突破12:=三角突破4 AND NOT(三角突破8 AND 三角突破9>=三角突破10);

三角突破13:=三角突破8 AND NOT(三角突破4 AND 三角突破9=三角突破10);

三角突破15:=REF(BARSLAST(三角突破11),1)+1;

三角突破16:=BACKSET(三角突破11 AND COUNT(三角突破13,三角突破15)>0,LLVBARS(IF(三角突破13,L,10000),三角突破15));

三角突破17:=三角突破16>REF(三角突破16,1);

三角突破18:=BACKSET(三角突破17,2);

三角突破19:=三角突破18>REF(三角突破18,1);

三角突破20:=三角突破19 OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;

三角突破21:=REF(BARSLAST(三角突破20),1)+1;

三角突破22:=BACKSET(三角突破20 AND COUNT(三角突破12,三角突破21)>0,HHVBARS(IF(三角突破12,H,0),三角突破21));

三角突破23:=三角突破22>REF(三角突破22,1);

三角突破24:=BACKSET(三角突破23,2);

三角突破25:=三角突破24>REF(三角突破24,1);

三角突破26:=BACKSET(ISLASTBAR,MIN(BARSLAST(三角突破25),BARSLAST(三角突破19))+1);

三角突破27:=三角突破26>REF(三角突破26,1);

三角突破28:=H;

三角突破29:=REF(H,REF(BARSLAST(三角突破25),1)+1)>REF(H,REF(BARSLAST(三角突破25),1)+2+REF(BARSLAST(三角突破25),REF(BARSLAST(三角突破25),1)+2));

三角突破30:=三角突破28 AND 三角突破29 AND 三角突破25;

三角突破31:=BACKSET(三角突破30,REF(BARSLAST(三角突破25),1)+2);

HH:=三角突破31>REF(三角突破31,1);

三角突破32:=L>REF(L,REF(BARSLAST(三角突破19),1)+1);

三角突破33:=REF(L,REF(BARSLAST(三角突破19),1)+1);

D4:=三角突破32 AND 三角突破33 AND 三角突破19;

E4:=BACKSET(D4,REF(BARSLAST(三角突破19),1)+2);

LL:=E4>REF(E4,1);

H3:=HH OR ISLASTBAR OR BARSCOUNT(C)=1;

X3:=REF(BARSLAST(H3),1)+1;

F3:=BACKSET(H3 AND COUNT(LL,X3)>0,LLVBARS(IF(LL,L,POW(10,20)),X3));

G3:=F3>REF(F3,1);

I3:=BACKSET(G3,2);

LZ:=I3>REF(I3,1);

L4:=LZ OR ISLASTBAR OR BARSCOUNT(C)=1;

X4:=REF(BARSLAST(L4),1)+1;

F4:=BACKSET(L4 AND COUNT(HH,X4)>0,HHVBARS(IF(HH,H,-POW(10,20)),X4));

G4:=F4>REF(F4,1);

I4:=BACKSET(G4,2);

HZ:=I4>REF(I4,1);

K1:=BACKSET(ISLASTBAR,MIN(BARSLAST(HZ),BARSLAST(LZ))+1);

K2:=K1>REF(K1,1);

UU:=BACKSET(ISLASTBAR,BARSLAST(三角突破19)+1);

VV:=UU>REF(UU,1);

WW:=BACKSET(VV,REF(BARSLAST(三角突破19),1)+2);

XX:=WW>REF(WW,1);

UU2:=BACKSET(ISLASTBAR,BARSLAST(三角突破25)+1);

VV2:=UU2>REF(UU2,1);

WW2:=BACKSET(VV2,REF(BARSLAST(三角突破25),1)+2);

X三角突破21:=WW2>REF(WW2,1);

前一低:=REF(L,BARSLAST(VV)),COLOR99FF66,LINETHICK2;

前二低:=REF(L,BARSLAST(XX)),COLORFF66FF,LINETHICK2;

前一高:=REF(H,BARSLAST(VV2)),COLOR99FF66,LINETHICK2;

前二高:=REF(H,BARSLAST(X三角突破21)),COLORFF66FF,LINETHICK2;

短高:=REF(H,BARSLAST(VV2));

短低:=REF(L,BARSLAST(VV));

短比:=(C-短低)/(短高-短低),NODRAW;

底:REF(L,BARSLAST(VV)),COLORYELLOW,LINETHICK2;

顶:REF(H,BARSLAST(VV2)),COLORGREEN,LINETHICK2;

XG:C>顶;

信号:=BARSLASTCOUNT(XG)=1;

STICKLINE(VV,顶,底,0,0),COLORFF6633,LINETHICK3;

DRAWLINE(VV2,H,VV,L,0),COLORBLUE,LINETHICK3;

DRAWLINE(VV2,H,VV,顶,0),COLORFF6633,LINETHICK3;

DRAWTEXT(ISLASTBAR,顶,STRCAT((”),CON2STR(顶,2))),COLORGREEN;

DRAWTEXT(ISLASTBAR,底,STRCAT((”),CON2STR(底,2))),COLORRED;

STICKLINE(VV2 ,顶,底,0,0),COLORRED,LINETHICK3;

DRAWLINE(VV,L,VV2,H,0),COLORRED,LINETHICK3;

DRAWLINE(VV,L,VV2,底,0),COLORRED,LINETHICK3;

通达信三角形画线突破主图指标公式源码

常见问题及下载声明: 1、指标不提供具体的使用方法,详情里一般会说明使用建议,需自行学习研究。 2、指标下载后,代表已对该指标认可,顾不退款! 3、指标不会安装,可在首页点击指标公式安装,各大软件指标安装教程。 4、指标是分析学习工具,不能依赖操作,仅供学习之用,依次操作,盈亏自负!

云析赢指标公式网首席工程师

相关文章

发表评论
暂无评论