#精品
文华财经boll交易辅助买卖预警指标公式

2024-07-10 0 71,350
指标编写逻辑条件:

条件1:前面有K线的最高价突破布林上轨并且c>布林中轨,现K线死叉MA5,后面的K线为绿色,金叉MA5后K线为红色!

条件2:前面有K线的最低价跌破布林下轨并且c<布林中轨,现K线金叉MA5,后面的K线为红色,死叉MA5后K线为绿色!

文华财经boll交易辅助买卖预警指标公式源码:

MID:MA(CLOSE,26);

TMP2:=STD(CLOSE,26);

TOP:MID+2*TMP2;

BOTTOM:MID-2*TMP2;

MA5:MA(C,5);

CROSSDOWN(C,MID)&&EXIST(H>TOP,BARSLAST(CROSS(C,MID))),SOUND(‘A’);

CROSSDOWN(C,MID)&&EXIST(H>TOP,BARSLAST(CROSS(C,MID))),NOTICE;

CROSSDOWN(C,MID)&&EXIST(H>TOP,BARSLAST(CROSS(C,MID))),ICON(0,’ICO4′),VALIGN0;

DRAWCOLORKLINE(ISDOWN=0,COLORWHITE,1);

DRAWCOLORKLINE(ISDOWN=1,COLORWHITE,0);

DRAWCOLORKLINE(CROSSDOWN(C,MID)&&EXIST(H>TOP,BARSLAST(CROSS(C,MID)))&&ISDOWN=0,COLORYELLOW,1);

DRAWCOLORKLINE(CROSSDOWN(C,MID)&&EXIST(H>TOP,BARSLAST(CROSS(C,MID)))&&ISDOWN=1,COLORYELLOW,0);

CROSS(C,MID)&&EXIST(L<BOTTOM,BARSLAST(CROSSDOWN(C,MID))),SOUND(‘B’);

CROSS(C,MID)&&EXIST(L<BOTTOM,BARSLAST(CROSSDOWN(C,MID))),NOTICE;

CROSS(C,MID)&&EXIST(L<BOTTOM,BARSLAST(CROSSDOWN(C,MID))),ICON(1,’ICO5′);

DRAWCOLORKLINE(CROSS(C,MID)&&EXIST(L<BOTTOM,BARSLAST(CROSSDOWN(C,MID)))&&ISDOWN=0,COLORMAGENTA,1);

DRAWCOLORKLINE(CROSS(C,MID)&&EXIST(L<BOTTOM,BARSLAST(CROSSDOWN(C,MID)))&&ISDOWN=1,COLORMAGENTA,0);

DRAWCOLORKLINE(C<MA5 && C>MID &&EXIST(H>TOP,BARSLAST(CROSS(C,MID)))&&ISDOWN=0,COLORGREEN,1);

DRAWCOLORKLINE(C<MA5 && C>MID &&EXIST(H>TOP,BARSLAST(CROSS(C,MID)))&&ISDOWN=1,COLORGREEN,0);

DRAWCOLORKLINE(C>MA5 && C>MID &&EXIST(H>TOP,BARSLAST(CROSS(C,MID)))&&ISDOWN=0,COLORRED,1);

DRAWCOLORKLINE(C>MA5 && C>MID &&EXIST(H>TOP,BARSLAST(CROSS(C,MID)))&&ISDOWN=1,COLORRED,0);

DRAWCOLORKLINE(C<MA5 && C<MID &&EXIST(L<BOTTOM,BARSLAST(CROSSDOWN(C,MID)))&&ISDOWN=0,COLORGREEN,1);

DRAWCOLORKLINE(C<MA5 && C<MID &&EXIST(L<BOTTOM,BARSLAST(CROSSDOWN(C,MID)))&&ISDOWN=1,COLORGREEN,0);

DRAWCOLORKLINE(C>MA5 && C<MID &&EXIST(L<BOTTOM,BARSLAST(CROSSDOWN(C,MID)))&&ISDOWN=0,COLORRED,1);

DRAWCOLORKLINE(C>MA5 && C<MID &&EXIST(L<BOTTOM,BARSLAST(CROSSDOWN(C,MID)))&&ISDOWN=1,COLORRED,0);

文华财经boll交易辅助买卖预警指标公式

常见问题及下载声明: 1、指标不提供具体的使用方法,详情里一般会说明使用建议,需自行学习研究。 2、指标下载后,代表已对该指标认可,顾不退款! 3、指标不会安装,可在首页点击指标公式安装,各大软件指标安装教程。 4、指标是分析学习工具,不能依赖操作,仅供学习之用,依次操作,盈亏自负!

云析赢指标公式网首席工程师

相关文章

发表评论
暂无评论