#最新
通达信主力资金异动净额主图幅图指标公式

2024-01-09 0 6,988

主力资金异动主图指标公式源码:

M5:=5;
M10:=10;
M22:=22;
M120:=120;
ZF:=(C-REF(C,1))/REF(C,1)*100;
EMA5:=EMA(C,M5),;
EMA10:=EMA(C,M10);
EMA22:=EMA(C,M22);
JFH:=EMA5>=EMA10 && EMA10>=EMA22;
FHW:=EMA22>=EMA10 && EMA10>=EMA5;
RSVK:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
XZQ:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
ZLL:=(EMA(XZQ,3)-50)*5,;
K1:=SMA(RSVK,10,1);
D1:=SMA(K1,5,1);
KK:=EMA(K1,2);
DD:=EMA(D1,2);
TFXXS:=KK+DD;
TGLXS:=(TFXXS-REF(TFXXS,1))*10;
TYCFX:=TFXXS+TGLXS;
XS2:=TGLXS>69;
XS3:=COUNT(ZLL>40,2)>0;
XS4:=XS2 AND XS3;
主力异动:=REF(XS4,1)=0 AND XS4 AND C>O;
主力异动1:=CROSS(主力异动,0.9);
STICKLINE(C,REF(C,BARSLAST(主力异动1)),REF(L,BARSLAST(主力异动1)),6,0),COLORC08080;
STICKLINE(C,REF(C,BARSLAST(主力异动)),REF(C,BARSLAST(主力异动)),4,1),COLORRED;
TT0:=BARSLAST(CURRBARSCOUNT=CONST(主力异动));
DRAWTEXT(TT0=0,REF(H,TT0)*1.003,VARCAT(VARCAT(‘牛线等突破 : ‘,VAR2STR(REF(H,TT0),2)),’元’))COLORWHITE;
EMA120:EMA(CLOSE,M120);
DRAWKLINE(H,O,L,C);
DRAWICON(CROSS(EMA5,EMA10),L,1);
DRAWICON(CROSS(EMA10,EMA5),H,2);
STICKLINE(JFH>REF(JFH,1),OPEN,CLOSE,2,0),COLOR4080FF;
STICKLINE(主力异动,OPEN,CLOSE,2,0),COLORYELLOW;
STICKLINE(ZF<-9.8,O,C,3,0),COLORGREEN;
STICKLINE(LOW >REF(HIGH,1),LOW,REF(HIGH,1),5,1),COLORRED;
STICKLINE(C<REF(C,1) AND REF(L,1)>H,REF(L,1),H,5,1),COLORMAGENTA;
DRAWTEXT(主力异动,EMA22,’主力异动’),COLORYELLOW,LINETHICK2;
VVAR1:=2*MA(LLV((C+L)/2,8)*1.1,13)-EMA((C+L)/2,3)-((C+L)/2)*0.1;
VVAR2:=IF((EMA((C+L)/2,3)-VVAR1)*5>0,POW((EMA((C+L)/2,3)-VVAR1)*5,2)/10,-1*POW((EMA((C+L)/2,3)-VVAR1)*5,2)/10);
VVAR3:=IF(VVAR2>0,VVAR2-0,0);
STICKLINE(VVAR3>0 AND REF(VVAR3,1)=0 AND (C+L)/2>MA((C+L)/2,8),OPEN,CLOSE,2,0),COLORFF00FF;
高不破价:=REF(C,BARSLAST(主力异动));
低不破价:=REF(L,BARSLAST(主力异动));
单阳不破:=CURRBARSCOUNT<100 AND BARSLAST(主力异动)<11 AND (LLV(L,BARSLAST(主力异动))>低不破价 OR LLV(L,BARSLAST(主力异动))=低不破价);
STICKLINE(单阳不破,低不破价-低不破价*0.0005,低不破价,4,0),COLORGREEN;
STICKLINE(单阳不破,高不破价,高不破价,4,0),COLORRED;
XGH:=CROSS(主力异动,0.9);
QF:=BACKSET(XGH=1,主力异动+1);
QFT:=BARSLAST(CROSS(QF=1,0.5));
NOTEXT:IF(QF=1,L,DRAWNULL),COLORGREEN;
STICKLINE(QFT>=0,REF(H,QFT),REF(H,QFT),4,-1),COLORYELLOW;
DRAWTEXT(QFT=0,H*1.03,VARCAT(VARCAT(‘异动价等突破:’,VAR2STR(REF(H,QFT),2)),’元’))COLORYELLOW;
LLT:=LLVBARS(L,60);
LTLT:=BARSLAST(CURRBARSCOUNT=CONST(LLT)+1);
HGT:=FINDHIGHBARS(H,LLT+1,60,1);
牛线:DRAWLINE(CURRBARSCOUNT=CONST(HGT)+1,H,ISLASTBAR,REF(H,HGT),0),COLORFF80FF,LINETHICK2;
牛线1:DRAWLINE(CURRBARSCOUNT=CONST(HGT)+1,H,ISLASTBAR,REF(H,HGT),0),COLORYELLOW,LINETHICK4,POINTDOT;
TGT0:=BARSLAST(CURRBARSCOUNT=CONST(HGT)+1);
DRAWTEXT(TGT0=0,REF(H,TGT0)*1.003,VARCAT(VARCAT(‘牛等突破 : ‘,VAR2STR(REF(H,TGT0),2)),’元’))COLORWHITE;

周月净额幅图指标公式源码:

N:=5;
M:=60;
均价:=(0.618*(0.809*C+0.191*O)+0.382*(IF(H=C,C,H)+IF(L=C,C,L))/2);
LJ:=IF(CAPITAL,均价,AMOUNT/(V*100));
GZ:=(C*0.618+(WMA(LJ,3)+WMA(LJ,5))/2+WMA(LJ,8)*0.382)/2;
跟庄线:=(REF(GZ,2)+REF(GZ,1)+REF(GZ,0))/3,COLORWHITE,LINETHICK1;
GZX:=(WMA(LJ,8)*0.618+(WMA(LJ,13)+WMA(LJ,21))/2+WMA(LJ,34)*0.382)/2;
工作线:=(REF(GZX,2)+REF(GZX,1)+REF(GZX,0))/3;
价差:=IF(H=L,1/40,(MIN(LJ,GZ)-REF(MAX(LJ,GZ),1))/REF(LJ,1));
系数:=IF(H=L,1/4,(1/C+1/(H-L)*0.618+1/ABS(C-O)*0.382));
误差:=IF(H=L,1/REF(C,1)-1/O,1/C-1/O);
AI:=价差*AMOUNT;
历史AI:=HHV(REF(价差*AMOUNT,1),0);
配比:=1/历史AI*系数*2/((1/L-1/H)+SGN(LJ-REF(LJ,1))*误差)/1000;
活跃净额:AI/CAPITAL/10,NODRAW;
纠差净额:AI/历史AI*配比,NODRAW;
周净额:SUM(活跃净额,N),NODRAW;
月净额:SUM(活跃净额,22),NODRAW;
累计:(EMA(活跃净额,13)+EMA(活跃净额,26)+EMA(活跃净额,42)+EMA(活跃净额,M))/4*20,RGB(128,0,128),COLORRED;
均值:EMA(累计,10),COLORWHITE;
STICKLINE(活跃净额>0,0,活跃净额,3,0),COLORRED;
STICKLINE(活跃净额<0,0,活跃净额,3,0),COLORGREEN;

指标截图:

通达信主力资金异动净额主图幅图指标公式

常见问题及下载声明: 1、指标不提供具体的使用方法,详情里一般会说明使用建议,需自行学习研究。 2、指标下载后,代表已对该指标认可,顾不退款! 3、指标不会安装,可在首页点击指标公式安装,各大软件指标安装教程。 4、指标是分析学习工具,不能依赖操作,仅供学习之用,依次操作,盈亏自负!

云析赢指标公式网首席工程师

相关文章

发表评论
暂无评论