#最新
通达信主力异动趋势多空幅图指标公式源码

2024-01-09 0 45,831

通达信主力异动牛股预警幅图源码:

VA1:=EMA(EMA(CLOSE,9),9);
VA2:=(VA1-REF(VA1,1))/REF(VA1,1)*1000;
VA3:=CROSS(VA2,0);
VA4:=MA(C,120);
VA5:=MA((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100,3);
VA6:=IF(CLOSE>VA4 AND REF(VA5,1)<30 AND VA5>REF(VA5,1) AND REF(VA5,1)<REF(VA5,2),10,0);
主力异动进入:VA3 AND VA6;
{抓连扳}
ZDF:=(C-REF(C,1))/REF(C,1)*100;
S0:=INBLOCK(‘创业板’);
S1:=IF(NAMELIKE(‘S’),0,1);
S2:=IF(NAMELIKE(‘*’),0,1);
S3:=VOL/CAPITAL*100;
S4:=S3*((H-L)+ABS(C-O));
S5:=S4/C;
S6:=NOT(S0) AND S1 AND S2;
抓连扳:S5<1.6 AND S6 AND ZDF>9.82;
{黑盘手牛股}
M1:=V/700000000;
M2:=1.1*(MAX(H,REF(C,1))/MIN(L,REF(C,1))-1);
M3:=2.5*MAX(M1,M2);
M4:=DMA(C,M3);
M5:=SMA(20*(M4/REF(M4,1)-1),2,1);
M6:=EMA(M5,2);
M7:=0.24;
M8:=C>=REF(C,1);
XX:= IF(M5>M7 AND M6>=0.005 AND M8,1,0);
XXX:=CROSS(XX,0.5) AND COUNT(XX>0.5,10)=1;
QB:=”KDJ.J”-REF(“KDJ.J”,1)>30 AND C/REF(C,1)>1.043 AND “MACD.MACD”>0 AND “MACD.DEA”>0;
LS:=C/REF(C,1)>1.048 AND C=H AND BETWEEN(FORCAST(V,4),0.2*FORCAST(V,12),2.1*FORCAST(V,12));
LQ:=FILTER(LS,28)*100 AND L>REF(C,1)*0.93;
XG:=QB OR LQ AND XXX;
M11:=9;
M12:=10;
B1:=C/REF(C,1)>1+0.01*M11;
B2:=EXIST(C/REF(C,1)>1+0.01*M11,M12);
B3:=C/REF(C,1)>1+0.01*M11;
MM:=IF(B1+B2+B3=3,1,0);
CC:=(H-C)/(C-O)<0.33;
DD:=(C/REF(C,1)-1)>=0.0502 AND C>REF(C,1) AND (O-L)/(C-O)>=1.48 AND L<REF(L,1) AND L<REF(L,2);
EE:=(C/REF(C,1)-1)>=0.08;
AA:=V>REF(V,1)*1.9 AND C>REF(C,1) AND C/REF(C,1)-1>=0.049 AND CC;
BB:=(C/REF(C,1)-1)>=0.0502 AND C>REF(C,1) AND V>REF(V,1) AND V>REF(V,1)*2.5 AND CC;
CCB:=EMA(2.055*EMA(EMA(H,34),34)-EMA(EMA(L,34),34),5),COLORCYAN,LINETHICK2;
YDXG:=IF(FILTER(AA OR BB OR DD OR EE AND CCB>C,34),1,0) AND MM;
LYQD:IF(XG OR YDXG,1.2,0),STICK,COLORMAGENTA,LINETHICK4;
DRAWTEXT(CROSS(LYQD,1),LYQD-LYQD*0.14,’ 牛股预警’),COLORMAGENTA;

通达信主力散户操盘线幅图指标公式源码:

散户操盘线:SLOPE(CLOSE,25),COLORLIGREEN,LINETHICK2;
主力操盘线:SLOPE(CLOSE,34),COLORRED,LINETHICK2;
X_1:=EMA(CLOSE,12);
X_2:=EMA(CLOSE,50);
X_3:=X_1>X_2 AND CROSS(散户操盘线,主力操盘线) AND 主力操盘线<0 AND CLOSE>X_2;
X_4:=CROSS(散户操盘线,主力操盘线) AND 主力操盘线<=(-0.04);
DRAWICON(X_3>0 OR X_4>0,0.05,24);
STICKLINE(X_3>0 OR X_4>0,0.1,主力操盘线,2.3,0),COLORFF0033;
STICKLINE(X_3>0 OR X_4>0,0.1,主力操盘线,1.8,0),COLORFF0066;
STICKLINE(X_3>0 OR X_4>0,0.1,主力操盘线,1.2,0),COLORFF0099;
STICKLINE(X_3>0 OR X_4>0,0.1,主力操盘线,0.6,0),COLORFF00CC;
STICKLINE(X_3>0 OR X_4>0,0.1,主力操盘线,0.3,0),COLORMAGENTA;

通达信主力多空趋势幅图指标源码:

DRAWGBK(C>0, RGB(0,10,10),RGB(48,0,0),0,’11’,0);
AA1:=(CLOSE-LLV(LOW,43))/(HHV(HIGH,43)-LLV(LOW,43))*100;
AA2:=SMA(AA1,2,1);
主力趋势:SMA(AA2,2,1),LINETHICK3,COLORFFCC66;
压力位:100,COLORRED;
支撑位:0,COLORGREEN;
中界:50,COLORFFAA00;
DRAWTEXT(ISLASTBAR,中界,’中界’),COLORFFAA00;
A:92,COLOR3399FF;
B:8,COLOR3399FF;
买:STICKLINE(CROSS(主力趋势,4),0,50,0,0),COLORRED;
DRAWICON(CROSS(主力趋势,4),58,1);
DRAWICON(CROSS(主力趋势,4),70,26);
卖:STICKLINE(CROSS(96,主力趋势),100,50,0,0),COLORGREEN;
DRAWICON(CROSS(96,主力趋势),40,2);
DRAWICON(CROSS(96,主力趋势),30,15);
IF(主力趋势>REF(主力趋势,1),主力趋势,DRAWNULL),COLORMAGENTA,LINETHICK3;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=2*(DIF-DEA);
MACD空头A:=MACD>0 AND MACD<REF(MACD,1) AND REF(MACD,1)>=REF(MACD,2);
均线空头A:=C<REF(C,1) AND REF(C ,1)>=REF(C,2) AND REF(C,2)>=REF(C,3);
趋势空头A:=主力趋势>89 AND (主力趋势<=REF(主力趋势,1));
空头买点:=趋势空头A AND MACD空头A AND 均线空头A;
MACD多头B:=MACD<0 AND MACD>REF(MACD,1) AND REF(MACD,1)<=REF(MACD,2);
均线多头B:=C>=REF(C,1) AND REF(C ,1)<=REF(C,2) AND REF(C,2)<=REF(C,3);
趋势多头B:=主力趋势<11 AND (主力趋势>=REF(主力趋势,1));
多头买点:=趋势多头B AND MACD多头B AND 均线多头B;
DRAWICON(多头买点,30,1);
DRAWICON(多头买点,40,7);
STICKLINE(多头买点,0,20,0.01,0),COLORRED;
DRAWICON(空头买点,70,2);
DRAWICON(空头买点,60,8);
STICKLINE(空头买点,100,80,0.01,0),COLORGREEN;

指标截图:

通达信主力异动趋势多空幅图指标公式源码

常见问题及下载声明: 1、指标不提供具体的使用方法,详情里一般会说明使用建议,需自行学习研究。 2、指标下载后,代表已对该指标认可,顾不退款! 3、指标不会安装,可在首页点击指标公式安装,各大软件指标安装教程。 4、指标是分析学习工具,不能依赖操作,仅供学习之用,依次操作,盈亏自负!

云析赢指标公式网首席工程师

相关文章

发表评论
暂无评论